神烦论坛

 找回密码
 立即注册
查看: 711|回复: 2

易语言编写GIF录制

[复制链接]

1

主题

4

帖子

11

积分

一级圣斗士

Rank: 1

积分
11
发表于 2016-3-8 16:28:39 | 显示全部楼层 |阅读模式
易语言编写GIF录制,高分屏下提前的到的图片大小与实际分辨率的不对。求高收解决
回复

使用道具 举报

1

主题

4

帖子

11

积分

一级圣斗士

Rank: 1

积分
11
 楼主| 发表于 2016-3-8 16:31:11 | 显示全部楼层
.版本 2

.程序集 窗口选择区域程序集
.程序集变量 开始画矩形, 逻辑型

.子程序 _窗口选择区域_创建完毕

窗口选择区域.左边 = 0
窗口选择区域.顶边 = 0
窗口选择区域.高度 = 取屏幕高度 ()
窗口选择区域.宽度 = 取屏幕宽度 ()
画板1.宽度 = 窗口选择区域.宽度
画板1.高度 = 窗口选择区域.高度
画板1.底图 = 快照 (, , )
开始画矩形 = 假
SetForegroundWindow (窗口选择区域.取窗口句柄 ())
回复 支持 反对

使用道具 举报

1

主题

4

帖子

11

积分

一级圣斗士

Rank: 1

积分
11
 楼主| 发表于 2016-3-8 16:33:11 | 显示全部楼层
.版本 2
.支持库 GIF89a
.支持库 eImgConverter

.程序集 启动窗口程序集
.程序集变量 动画制作, 合成动画
.程序集变量 帧信息, 帧信息
.程序集变量 动画信息, 动画信息
.程序集变量 上一图片, 字节集
.程序集变量 延迟时间, 整数型
.程序集变量 帧数量, 整数型
.程序集变量 鼠标水平位置, 整数型
.程序集变量 鼠标垂直位置, 整数型
.程序集变量 矩形, 数据类型矩形
.程序集变量 集储存路径, 文本型
.程序集变量 集热键标识, 整数型

.子程序 _按钮录象_被单击

_标签录像反馈_反馈事件 (0, 0)

.子程序 _按钮保存_被单击

.如果真 (通用对话框1.打开 ())
    动画制作.保存GIF图片 (通用对话框1.文件名)
.如果真结束


.子程序 _时钟1_周期事件
.局部变量 bmp, 字节集
.局部变量 x, 整数型
.局部变量 y, 整数型
.局部变量 i, 整数型

bmp = 快照 (, , )
x = 取鼠标水平位置 ()
y = 取鼠标垂直位置 ()
.如果 (bmp ≠ 上一图片 或 x ≠ 鼠标水平位置 或 y ≠ 鼠标垂直位置)
    上一图片 = bmp
    鼠标水平位置 = x
    鼠标垂直位置 = y
    i = 载入图片 (bmp)
    画板1.画图片 (i, 0, 0, , , )
    卸载图片 (i)
    .如果真 (选择框鼠标.选中)
        i = 载入图片 (#光标)
        画板1.画图片 (i, x, y, , , )
        卸载图片 (i)
    .如果真结束
    画板1.复制 (矩形.左边, 矩形.顶边, 矩形.宽度, 矩形.高度, 画板目标, 0, 0, )
    bmp = 画板目标.取图片 (, )
    帧信息.延迟时间 = 延迟时间
    延迟时间 = 50

    .如果 (单选框压缩.选中)
        处理事件 ()
        写到文件 (取运行目录 () + “\temp.bmp”, bmp)
        转换到JPG (取运行目录 () + “\temp.bmp”, 取运行目录 () + “\temp.jpg”, 选择框黑白.选中, 75, 真, 0)
        动画制作.加入帧图片 (帧信息, 取运行目录 () + “\temp.jpg”, )
    .否则
        动画制作.加入帧图片 (帧信息, , bmp)
    .如果结束
    帧数量 = 帧数量 + 1
.否则
    延迟时间 = 延迟时间 + 到数值 (组合框时钟周期.内容) ÷ 10
.如果结束
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

技术支持
关闭
售后
在线客服
QQ群:309604797
在线客服

小黑屋|神烦论坛 ( 苏ICP备18043773号 )

GMT+8, 2020-9-25 23:51

Powered by bby! X3.4

© 2015-2020 baibaoyun

快速回复 返回顶部 返回列表